Forum Navigation
You need to log in to create posts and topics.

fail to load pip installed ovito on CentOS

Hi!

I am currently working on a remote machine running CentOS 7 with intel python 3.6.3 installed. I used pip install -U ovito to install ovito successfully. However, when I was trying to import ovito, the following error shows up:

$ python3 -c "import ovito"
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/home/yfwang09/.local/lib/python3.6/site-packages/ovito/__init__.py", line 19, in <module>
from .plugins.PyScript import (version, version_string, gui_mode, headless_mode, Scene, scene, dataset, enable_logging)
File "/home/yfwang09/.local/lib/python3.6/site-packages/ovito/plugins/__init__.py", line 18, in <module>
import ovito.plugins.ovito_bindings
ImportError: /home/yfwang09/.local/lib/python3.6/site-packages/PySide2/Qt/lib/libQt5Core.so.5: version `Qt_5.14' not found (required by /home/yfwang09/.local/lib/python3.6/site-packages/ovito/plugins/ovito_bindings.so)

The PySide2 I have on my python3 is 5.13.2:

$ python3 -c "import PySide2; print(PySide2.__version__)"
5.13.2

Do you know why this happen and how to solve it?

Thanks!
Yifan

Hi Yifan,

I will need to check if there is something wrong with the current OVITO PyPI packages. The error message seems to suggest that the package depends version 5.14.x of the PySide2 package, i.e. one that is newer than your currently installed version.

My suggestion for you would be to upgrade PySide2 to the latest available version (5.14.2) by running

pip install -U PySide2

Then try again to import the ovito module and let me know if that works.

-Alex

Hi Alex,

Thanks! I have tried upgrade PySide2 my self, and the ovito package works just fine.

Yifan

Good.

In the meantime I have raised the dependency requirement of the ovito package to PySide2>=5.14. Thus, PySide2 should now get automatically upgraded by the pip command whenever you upgrade the Ovito package.