Forum Navigation
You need to log in to create posts and topics.

installation: ovito module, university cluster

Dear all,

 

i tried to install the ovito module at my university cluster, by

python3 -m pip install -U ovito

and here is the output:

 

Collecting ovito
Using cached https://files.pythonhosted.org/packages/1c/cf/ff0630ad6640b0cb47b04c0aa8446d60b543151f28bc10441baf0bd73f5a/ovito-3.7.4-cp36-cp36m-manylinux1_x86_64.whl
Collecting PySide6>=6.2 (from ovito)
Using cached https://files.pythonhosted.org/packages/75/6c/110c821dbedb3657e715bac48adc568c1a7e8347c73e6038d0c595280d63/PySide6-6.2.4-6.2.4-cp36.cp37.cp38.cp39.cp310-abi3-manylinux1_x86_64.whl
Collecting numpy (from ovito)
Using cached https://files.pythonhosted.org/packages/45/b2/6c7545bb7a38754d63048c7696804a0d947328125d81bf12beaa692c3ae3/numpy-1.19.5-cp36-cp36m-manylinux1_x86_64.whl
Collecting traits (from ovito)
Using cached https://files.pythonhosted.org/packages/19/ac/012074e5034502fa184b5efeb2eed2fdb764bf62baeae9f26584204ba69c/traits-6.3.2-cp36-cp36m-manylinux_2_5_x86_64.manylinux1_x86_64.manylinux_2_12_x86_64.manylinux2010_x86_64.whl
Collecting shiboken6==6.2.4 (from PySide6>=6.2->ovito)
Using cached https://files.pythonhosted.org/packages/89/d0/59e7c52f5af5bc97142edc61a5d2437b8c81b943c7d2a8ee98acf85273b7/shiboken6-6.2.4-6.2.4-cp36.cp37.cp38.cp39.cp310-abi3-manylinux1_x86_64.whl
Installing collected packages: shiboken6, PySide6, numpy, traits, ovito
Exception:
Traceback (most recent call last):
File "/usr/lib/python3.6/site-packages/pip/basecommand.py", line 215, in main
status = self.run(options, args)
File "/usr/lib/python3.6/site-packages/pip/commands/install.py", line 365, in run
strip_file_prefix=options.strip_file_prefix,
File "/usr/lib/python3.6/site-packages/pip/req/req_set.py", line 789, in install
**kwargs
File "/usr/lib/python3.6/site-packages/pip/req/req_install.py", line 854, in install
strip_file_prefix=strip_file_prefix
File "/usr/lib/python3.6/site-packages/pip/req/req_install.py", line 1069, in move_wheel_files
strip_file_prefix=strip_file_prefix,
File "/usr/lib/python3.6/site-packages/pip/wheel.py", line 345, in move_wheel_files
clobber(source, lib_dir, True)
File "/usr/lib/python3.6/site-packages/pip/wheel.py", line 287, in clobber
ensure_dir(dest) # common for the 'include' path
File "/usr/lib/python3.6/site-packages/pip/utils/__init__.py", line 83, in ensure_dir
os.makedirs(path)
File "/usr/lib64/python3.6/os.py", line 210, in makedirs
makedirs(head, mode, exist_ok)
File "/usr/lib64/python3.6/os.py", line 220, in makedirs
mkdir(name, mode)
PermissionError: [Errno 13] Permission denied: '/usr/local/lib64/python3.6'

 

 

before writing an email to our cluster (in this forum  people are much nicer 🙂  ),

i wanted to check out here ...

 

kind regards,

vardan.

 

 

 

 

Hi,

thanks for your nice words, but I'm afraid this permission error suggests that should actually contact your university's hpc staff. They will be able to give you much more specific directions.

This might be due to a fairly old version of the pip module on your cluster. Have you already tried using the --user command line option with the pip install command? This option makes sure that the packages are getting installed in your home directory and not the system directory (where you don't have write permissions). See here:

https://stackoverflow.com/questions/31512422/pip-install-failing-with-oserror-errno-13-permission-denied-on-directory

Also note that your Python interpreter is fairly old (Python 3.6). That old version of Python has reached its end of life, and future versions of the OVITO module will no longer run on this interpreter anymore. But this is just for your information. It's probably not the reason for this specific installation issue.

Dear Constanze

 

thanks  (i knew it 😀 )

 

regards,

vardan.

新的OVITO微信频道!
New for our users in China: OVITO on WeChat 

Official OVITO WeChat channel operated by Foshan Diesi Technology Co., Ltd.