Forum Navigation
You need to log in to create posts and topics.

Open GL rendering

Hi,

I used OpenGL to refering a figure in my AMD laptop, but the quality is disappointing. The figure 1 and 2 use 3 and 6 Antialiasing level.

I do it in another PC to do it and I find it good enough. The CPU of this PC is Intel(R) Xeon(R) CPU E5-2670. I don't kown whether the problem is the AMD compatibility issues.

Follows is my laptop info:

CPU: AMD Ryzen 5 3500H with Radeon Vega Mobile Gfx  2.10GHz

RAM: 16GB

OS: Windows 10 x64

I want to buy a new PC and want to forbiden this issue. Can you give me some advice? Thanks for your timely help.

Best, Wang

Uploaded files:
  • figure_1.png
  • figure_2.png

Hi,

I am not aware of any specific AMD graphics incompatibility that could explain this, but we can try to investigate this further.

How did you manage to render the same picture on different computers? Did you save the visualization setup as a .ovito file or did you recreate the visualization in OVITO on the second computer?

If possible, please send me the .ovito file including the simulation data file. I would like to test the rendering output on some of our computers and try to reproduce the artifacts. Thanks.

If you consider buying new hardware, I can recommend any graphics card from Nvidia. In the past, we had almost no reports of compatibility issues from users with Nvidia hardware.

-Alex

Hi,

I never heard others' complaint about this problem. So I thick it's maybe my laptop's issue. I have tested the same file on other PCs and it worked well.

For smaller size file, I use another data file. The problem got even worse. See the figure 3. I upload the for_test.ovito and .data file. The .ovito file is not allowed to upload, so  I modified the name to for_test.data. You may changed it back to for_test.ovito. 

Uploaded files:

Hi,

Quote from Alexander Stukowski on August 19, 2020, 12:51 pm

If you consider buying new hardware, I can recommend any graphics card from Nvidia. In the past, we had almost no reports of compatibility issues from users with Nvidia hardware.

-Alex

 

I thinck your sugestion is really correct. It's better not to use AMD Radeon graphical card (RX 5600XT). I buy a PC with intel CPU and Radeon GPU. The Open GL redering is really bad, like I uploaded  before. Can you give me some advice  for my situation?

I sincerely suggest NOT to use ovito with AMD Radeon. 🙁 Please use PC with Nvidia GPU.   I don't kown how to deal with that.

- Wang

 

Hi,

I hava found that the problem is that the atoms in some blocks are missing when using openGL renderer whatever the numbers of atoms in whole model is. If the thickness of model is not enough, the rendering figure seems like losing some blocks. This problem is fixed when I switch the renderer to Tachyon or OSRay. But I still  want to kown why this happen, because the quality of openGL is good enough for publication and its high speed.

I am sure the problem is rare (never found in others PC). Can you help me deal with that?

-Wang

Yes, that is what I suspected from the last picture that you posted above. The graphics card silently drops some of the atoms that it receives from OVITO for rendering. I have seen this phenomenon before, which seems occur only on very specific graphics hardware/driver/operating system combinations. Unfortunately, the reason for this behavior is not know yet. The same OpenGL graphics function calls made by OVITO work flawlessly on the majority of systems. Most likely it is a bug in the OpenGL graphics driver or incompatibility with the OpenGL specification, which hasn't been discovered and fixed by the vendor yet (because they mostly focus on games, which typically use slightly other OpenGL functions).

Perhaps, it is possible to develop a workaround for this problem. However, in order to do that, I would need to set up a development machine containing the problematic graphics hardware. So far I didn't get the chance to get hold of such a graphics card model and we don't own PCs with replaceable graphics hardware. But I'll keep looking.

Could you please do one more thing: In OVITO's Help menu, select "OpenGL Information", and copy/paste the displayed system information here. The info will tellsme some more about the exact driver version and graphics hardware model OVITO is running on. Thank you.

Finally, note that you can change the quality mode for the particle display in this panel from "Auto" to some other mode. Setting the mode to "Low", for example, will force OVITO to use the same rendering technique both for the interactive viewports and when rendering a static image. On your system, mode "Low" may actually show less artifacts than mode "High".

Hi,

Thanks for your explanation. Follows is the OpenGL info in my PC:

======= System info =======

Date: Thursday 8/27 20:34:50 2020

Application: Ovito 3.2.0

OS: Windows (192)

Architecture: 64 bit

Floating-point size: 64 bit

Qt version: 5.12.6

Command line: D:\Software\OVITO Basic\ovito.exe C:\Users\A\Desktop\traj.1900000.cfg

======= OpenGL info =======

Version: 3.2

Profile: core

Alpha: 1

Vendor: ATI Technologies Inc.

Renderer: AMD Radeon RX 5600 XT

Version string: 3.2.13596 Core Profile Context 20.5.1 27.20.1017.1011

Swap behavior: double buffer

Depth buffer size: 24

Stencil buffer size: 8

Shading language: 4.60

Geometry shaders supported: yes

Using deprecated functions: yes

Using point sprites: yes

Using geometry shaders: no

Context sharing enabled: yes

 

It's exciting that your last  suggestion works! 🙂 The low mode really show great quality. I have spent much time on that. Thanks for your effitient guidance. Hope some others have the same problems can know this tip, or maybe low can be the default mode?

Best,

-Wang