Forum Navigation
You need to log in to create posts and topics.

running ovito- missing libraries?

Hello,

I'm trying to run ovito in ubuntu and I'm getting the following error (attached). I realize this is a common problem, but I'm having trouble locating which libraries I'm missing. I checked to make sure I have the libraries that have caused some other people this problem, but this hasn't worked so far so I would appreciate any guidance. I have also attached a .txt file with the output from ld_debug=libs.

Thank you!

Uploaded files:

Hi,

Just to double-check: Does the problem still occur after following the instructions given in our manual in section "Missing XCB system libraries"?

https://www.ovito.org/docs/current/installation.html#troubleshooting

And could you please clarify which version of OVITO this is? It doesn't seem to be the precompiled package for Linux, which we offer on our website. Did you build OVITO from source on your Ubuntu machine?

Providing the output from LD_DEBUG=libs was a good idea, but your log file appears to be incomplete. I think the important part (from the beginning of the output) is missing. Could you please try again recording all output during the startup phase of OVITO? These instructions may help.

-Alex

Hi thanks for your reply,

Yes I installed all the required libraries and some others that weren't mentioned there.

 

Yes, I built ovito from source . I tried redirecting stderr to the .txt file but the output seems to be starting in the same place. I'm not sure what I'm doing wrong here.

To clarify, when I run ld_debug=libs on its own it also gives the same output.

The LD_DEBUG output doesn't contain any indications that a system library fails to load or is missing. Perhaps there really is a problem with the X window display. At least that's what this error message suggests:

qt.qpa.xcb: could not connect to display

Are you logged in directly on the Ubuntu machine, or are you accessing it from remote via SSH? Note that the OVITO application - like most Qt-based applications - only runs locally and not through a SSH connection with X forwarding.

Hi, the issue was that I am on windows wasn't using WSL. Thank you for helping me figure that out!

I see.

In principle it is possible to run OVITO under WSL2 (not WSL1), but it requires using the Wayland platform plugin of Qt (not the XCB/X Window plugin).

新的OVITO微信频道!
New for our users in China: OVITO on WeChat 

Official OVITO WeChat channel operated by Foshan Diesi Technology Co., Ltd.