Forum Navigation
You need to log in to create posts and topics.

installation problem

Hello Ovito team:

I have trouble when install ovito-basic-3.1.3.

The error was showed on the picture:

 

 

Uploaded files:
  • error.png

Hi,

This error may have different reasons. We need to check which one it is in your case. Let's start with the most likely one:

Older OVITO packages for Linux, like the one you are trying to install, did not contain the Xinerama system library, which is required by OVITO. It may thus be necessary to install that library first. On Ubuntu/Debian based Linux distributions, you can install the package libxcb-xinerama0 using the package manager:

sudo apt-get install libxcb-xinerama0

-Alex

My system is centOs, cannot run apt-get command, what shululd I do ?

Please have a look here. This page contains some specific troubleshooting instructions for CentOS systems. Try running the last sudo yum install command to install the system packages required by OVITO.

Hello,

I keep getting the same error, even after installing the mentioned libraries. What else could be the problem? Thank you!

I'm using ovito 3.5.1 basic on a fresh gnome/debian virtual machine. The problem is probably not related to the fact that I'm dealing with a VM as I have the same problem with my dekstop machine. I was testing with the VM only to be sure that the problem is not due to potentially conflicting packages on my desktop machine.

Ovito 3.1.0 basic runs without problem.

Uploaded files:
  • ovito.png

I have no prior experience with the gnome/debian distribution. To help me determine which system library is missing in your case, please run:

LD_DEBUG=libs ./bin/ovito &> log.txt

and send me the file log.txt. Thanks.

-Alex

Thank you very much for your prompt reply. Here is the file.

Daniel

Uploaded files:

Thanks.

It may be the Debian package libxcb-util1 that needs to be installed in addition to the other packages you already installed. It contains the missing library libxcb-util.so.1, which seems to be responsible for the failure at program startup.

Debian -- File list of package libxcb-util1/sid/amd64

Thank you very much, this solved the problem for me.

Just in case someone else has a similar issue:

libxcb-util1 does not exist in the standard repositories of debian buster. It is available in the testing repository, though. It can be added by following this procedure: https://www.kvraudio.com/forum/viewtopic.php?t=560894

Be careful to run sudo apt-get update before installing with aptitude -t testing install libxcb-util1. This is not mentioned in the forum entry cited above.

I am not a specialist, and I am not certain whether adding the testing repository may cause other problems. For me, however, at least ovito seems to run fine after following these steps.

Thank you again!

新的OVITO微信频道!
New for our users in China: OVITO on WeChat 

Official OVITO WeChat channel operated by Foshan Diesi Technology Co., Ltd.