Forum Navigation
You need to log in to create posts and topics.

fail to open ovito

i install ovito with the version ovito-pro-3.0.0-dev653 successfully,but i fail to open it. A stopped working error occurred. My computer memory is 4GB.Besides, I can open the old version ovito-2.9.0-win64.

THANK YOU.GOOD LUCK!

Hi,

This is a very generic type of error message, and it's difficult to tell from here what is the actual reason for the program crash is. Since it happens at application startup, it could be a compatibility problem with the graphics driver. But that is just speculation.

Is this the first build from the Ovito 3.0.0 release series you tried to run (after having used OVITO 2.9.0 in the past)?

To diagnose the problem, it would be helpful for me to get a process memory dump from you. There is a Microsoft command line utility named "procdump" , which allows writing a process dump file when the application crashes:

https://docs.microsoft.com/en-us/sysinternals/downloads/procdump

Please install it and run the tool from the terminal as follows to collect crash information for Ovito:

C:\>procdump -ma "C:\Program Files\Ovito Pro\ovito.exe"

You can send me the resulting .dmp file, and I will try to find out more about the reason why Ovito 3.0.0 crashes on your computer. A second thing you can do is try running the "ovitos.exe" script interpreter in the Windows terminal window:

C:\>"C:\Program Files\Ovito Pro\ovitos.exe"

I am wondering if the script interpreter crashes as well. If so, it likely is not a problem with the graphics driver but some other issue.

-Alex

Thanks, Alex. I  build ovito3.0 multiple times but fail to open the ovito.exe. I can open the ovitos.exe. I fail to install the procdump.

When I use the command you recommend, ''It's not an internal or external command, it's not a runnable program or batch file ''occurs.

When I use the second command, ''This is OVITO's interactive Python interpreter. Use quit() or Ctrl-Z to exit.''occurs.

THANKS FOR YOUR REPLY! GOOD LUCK!

 

 

Thanks for the update. The fact that ovitos.exe runs but ovito.exe does not suggests that the program crash happens during initialisation of the OpenGL graphics viewports, because that is something only the ovito.exe application does at program startup.

Please check the installation of the graphics driver on your system. Maybe there is an update from your hardware vendor that you can install. Find out which graphics driver is currently installed and let me know the driver version number, hardware vendor name and graphics card or graphics chip model name.

To run the "procdump" utility, you may have to specify the full path where you have installed the downloaded executable. Thus, replace procdump with C:\<download path>\procdump, where <download path> is the directory where you have saved the procdump executable.

Thanks,Alex.

My graphics chip is Nvidia GeForce GT 630M.Driver version number is 23.21.13.9135.

When I use the procdump, the following appears on the terminal:

ProcDump v9.0 - Sysinternals process dump utility
Copyright (C) 2009-2017 Mark Russinovich and Andrew Richards
Sysinternals - http://www.sysinternals.com

No process matching the specified name can be found.
Try elevating the command prompt or using PsExec to make one as SYSTEM.
psexec.exe -s -d -i cmd.exe
procdump.exe -accepteula ...

 

Hi,

I'm sorry my instructions were insufficient. I should have first checked the procedure myself, but I didn't have access to a Windows computer on the weekend.

You can find a better description of how to use the "procdump" tool here (Note that this is an article from another software vendor):

https://kb.acronis.com/content/27931

For capturing a process dump of OVITO, you (probably) have to run the following command from a Windows command prompt with administrator privileges (see the article):

procdump64 -e -ma -w ovito.exe

Note you need to use the 64-bit version of procdump here, because OVITO is a 64-bit application. Procdump will wait until you start up OVITO, which you can do as usual through the Windows start menu. When OVITO crashes, procdump should automatically write a dump file in the directory where you have started it and then terminate.

Let me know if you need further help with this.

-Alex

Dear Alex:

Very thanks for your patience and help. I run the procdump64 with your command, the following information occurs,

Process: ovito.exe (11092)
Process image: C:\Program Files\Ovito Pro\ovito.exe
CPU threshold: n/a
Performance counter: n/a
Commit threshold: n/a
Threshold seconds: n/a
Hung window check: Disabled
Log debug strings: Disabled
Exception monitor: Unhandled
Exception filter: [Includes]
*
[Excludes]
Terminate monitor: Disabled
Cloning type: Disabled
Concurrent limit: n/a
Avoid outage: n/a
Number of dumps: 1
Dump folder: C:\Users\Administrator\
Dump filename/mask: PROCESSNAME_YYMMDD_HHMMSS
Queue to WER: Disabled
Kill after dump: Disabled

Press Ctrl-C to end monitoring without terminating the process.

[14:22:56] Exception: C0000005.ACCESS_VIOLATION
[14:22:56] Unhandled: C0000005.ACCESS_VIOLATION
[14:22:56] Dump 1 initiated: C:\Users\Administrator\ovito.exe_200211_142256.dmp
[14:22:56] Dump 1 writing: Estimated dump file size is 260 MB.
[14:22:59] Dump 1 complete: 260 MB written in 2.6 seconds
[14:22:59] Dump count reached.

I am very grateful for your help.

THANK YOU AGAIN.GOOD LUCK!

Okay, it looks like the crash dump file was successfully written. Please send me the file 'ovito.exe_200211_142256.dmp' for further analysis.

I am going to send you a link to your email address through which you can upload the file --in case you do not already have any other means to transfer the file to me.

I have send the file to you. Thank you !