Forum Navigation
You need to log in to create posts and topics.

/lib64/libc.so.6: version `GLIBC_2.14' not found

Hi Ovito team,

I tried to install ovito's Python package on a cluster without a network using the following command.

pip install --no-index --find-links=ovito-3.3.2-cp38-cp38-manylinux1_x86_64.whl -r requirements.txt

The installation was successful, but an error will be reported for import as shown in the picture.

How can I solve this problem?

shiboken2-5.15.1-5.15.1-cp35.cp36.cp37.cp38.cp39-abi3-manylinux1_x86_64.whl
PySide2-5.15.1-5.15.1-cp35.cp36.cp37.cp38.cp39-abi3-manylinux1_x86_64.whl
ovito-3.3.2-cp38-cp38-manylinux1_x86_64.whl

Above is the content in Requirements. txt

 

Thanks in advance!

Uploaded files:
  • 16066224601.png

Hi,

The screenshot suggests that your are using an Anaconda Python interpreter and not a plain CPython interpreter. The pip wheels you are trying to install were built for the standard CPython interpreter and are typically incompatible with Anaconda's Python interpreter. This may be the reason why you are getting this error message. Have you already tried installing the Anaconda packages instead?

You can download the OVITO package file for the Anaconda environment (Python interpreter 3.8) here in case you need to install it offline:

http://conda.ovito.org/linux-64/

Make sure you also download and install the ospray_ovito package (version 2.2.0). The PySide2 and shiboken2 packages, which are required by the ovito package, are available from the conda-forge project: