Forum Navigation
You need to log in to create posts and topics.

Missing Modifier

Hi Ovito Team,

I have installed  Ovito on my computer (Linux mint),

I have downloaded and installed  both Ovito Basics and Ovito Pro following the link:

https://www.ovito.org/linux-downloads/

I have also tried:

sudo apt-get install -y ovito.

With all this 3 approaches I believe some futures are missing.

For instance under the 'cutoff radius' as you can see on the attached image there is no option called ' Partial distribution function'.

Also under The histogram modifier I could not locate the settings of the Histogram Modifier to activate the option "Use only selected"

Thanks in advance!

Uploaded files:
  • missing.png

Hi Linda,

from the screenshot you posted I can see that you opened an older version of OVITO, i.e. OVITO 2.9, hence the "missing" modifier option, that didn't exist yet in the older version.

Could it be that you have an older system-wide installation of OVITO that you open instead of OVITO Basic or OVITO Pro?

Please first remove the ovito installation you installed from the apt-repository, since this has not been provided by us and is also not maintained by us.

To open OVITO Basic or OVITO Pro, either double click on the executables in the respective folders or execute e.g.

cd <path-to-your-ovito-installation>/ovito-pro-3.3.1-x86_64/bin/
./ovito

or e.g.

<path-to-your-ovito-installation>/ovito-pro-3.3.1-x86_64/bin/ovito

 

Hi Constanze,

Thank you!

When I do the following:

<path-to-your-ovito-installation>/ovito-pro-3.3.1-x86_64/bin/ovito

I have the following error.

qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: minimal, offscreen, vnc, xcb.

Aborted (core dumped)

Hi Linda,

This error message can have several different reasons. For example, it could mean that you are trying to start OVITO in an environment without a display (e.g. through a SSH remote connection). But it could also mean that there is conflict with another installation of the Qt libraries on the same Linux machine. The Qt libraries are required for the graphical user interface of OVITO and a copy of these libraries is included in the program package. But under certain circumstances a conflict with other incompatible installations of the same libraries on the system may arise.

BTW, another OVITO previously reported the same kind of error message here.

First, could you please confirm that you are trying to run OVITO on your local machine (and not on a remote machine or inside a virtual machine)? We can then try to narrow down the problem further. Thanks.

-Alex

Linda, in case your problem is not already resolved:

We just had another user report the same problem and installing the libxcb-xinerama library, which is a new dependency of Qt 5.15 fixed it.

sudo apt-get install libxcb-xinerama0

If that does not solve your problem, could you please run

LD_DEBUG=libs <your-path>/ovito-pro-3.3.1-x86_64/bin/ovito &> error.txt

and send us the textfile error.txt?

-Constanze

Update:
The newly released version 3.3.2 of OVITO for Linux now includes a copy of the Xinerama library. Manually installing that system library should not be required anymore.