Forum Navigation
You need to log in to create posts and topics.

Running ovitos

I had a problem running ovitos on Linux Mint

Using ovito-3.0.0-dev603-x86_64 I extract the files and attempt to run ovitos from the bin folder but I receive the message

qt5ct: using qt5ct plugin
Traceback (most recent call last):
File "/usr/bin/../lib/ovito/plugins/python/ovito/__init__.py", line 24, in <module>
import ovito.vis
File "/usr/bin/../lib/ovito/plugins/python/ovito/vis/__init__.py", line 36, in <module>
import PyQt5.QtGui
ImportError: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.13' not found (required by /home/username/.local/lib/python3.6/site-packages/PyQt5/QtGui.so)
ERROR: Failed to initialize Python interpreter.

I installed Qt_5.13, updated all libraries, ovito by itself runs fine I can open the ovito gui and use it without any problems. I just cannot call ovitos in the terminal

PyQt5 Version: 5.13.1

Based on the error message I guess that you extracted version dev603 of Ovito over an older installation of the program. This may have failed for some reason. The file "lib/ovito/plugins/python/ovito/vis/__init__.py" mentioned in the error message appears to be still from an old version of Ovito.

Please completely remove the directory /usr/lib/ovito/, and then extract the archive for Ovito-3.0.0-dev603 again. Let's see if that helps.

Thank you for the quick reply. I did have an older installation of Ovito and removing the /usr/lib/Ovito folder got rid of the error message, but now I receive the message: "ovitos: error while loading shared libraries: libCore.so: cannot open shared object file: No such file or directory".

Initially, I was receiving the same message about libGui.so but after I copied libGui.so along with all of the other files in ovito-3.0.0-dev603-x86_64/lib/ovito into /usr/lib/ovito the message went away. But I cannot find libCore.so anywhere after extracting the files.

How exactly did you extract the dev603 archive into the /usr/ system directory? I have the feeling that something still went wrong and some more file have not been replaced with the new versions. Perhaps you have to explicitly tell the 'tar' program to overwrite existing versions of the files in the system directory.

My guess is that the 'ovito' and the 'ovitos' executables in the /usr/bin/ directory have not been updated. In other words you are still running 'ovitos' from an old OVITO installation. Note that in build dev603 the libraries 'libGui.so' and 'libCore.so' no longer exist, and 'ovitos' should no longer be looking for them. Instead you now find 'Gui.so' and 'Core.so' in the /usr/lib/ovito/plugins/ directory.

Dear All,

I am having exact problem. I was using python 3.8 on Windows 10 and Pyqt5 was installed. I wanted to use scale bar script provided here ( https://www.ovito.org/manual/viewport_overlays.python_script.html ) then Script was throwing error. Then uninstalled everything. I installed Ovito 3.0.0 dev609 version, Anaconda 2019 with python version 3.7 64 bit. I installed PyQt5 with pip install command. Whatever I tried  I got the below error message:

"

The Python script has exited with an error.

Traceback (most recent call last):

File "<string>", line 1, in <module>

ModuleNotFoundError: No module named 'PyQt5.QtCore' "

 

I switched  to Ubuntu 18.04 and installed PyQt5 by pip command downloaded ovito for linux extracted the file then run the ovito in the bin folder. again same error.

Garip,

In your case you seem to be using an older version of the script, which is not compatible with more recent builds of OVITO 3.0. Please refer to this page for an up-to-date version of the same script:

https://ovito.org/docs/current/python/introduction/examples/overlays/scale_bar.php

The documentation found under the URL https://www.ovito.org/manual/ is outdated! Unfortunately, the Google search index and other places still contain links to these dead pages.

Current versions of OVITO no longer use the PyQt5 Python module. They now use PySide2 instead.

-Alex